We have a lot of people using RaceTab for TFRRS uploads now, so we had some new issues arise... specifically people who download the entries and want to import them from a delimited file instead of the "download from TFRRS" on the main page.

There were also a few other issues that arose with the TFRRS upload failing with various non-standard settings selected. So also updated to handle those better.

Finally updated some options in the Import from Delimited File screen. It will now pre-select to import into the last event you selected in the parent window. Also the Presets for XNote Stop watch and other timers work better now. It wasn't "tripping" the times columns automatically, unless you specifically clicked on times. Now if you choose a Preset then it should know it is times and adjust the columns accordingly.

Please let me know if you run into any other issues and we'll turn around a fix for you quickly!

Views: 204

Reply to This

Replies to This Discussion

Is there a messag within RT that indicates if the TFRRS export went thru?  I am trying to upload David Lustig's results mentioned above.  Updated to 407, changed scoring to on, but when I select the TFRRS export and have both the 'upload to API' and separation by 'overall' (which I assume is the default?) nothing seems to happen?

It should tell you either way. If there is an error reported, it comes up with that. If it succeeds it tells you that it worked and asks if you want to view the results in a web browser.

Like when I try to upload Dave's results it reports that I don't have permission (as it should). This is because I'm not the owner of that meet in TFRRS/DA.

I am logged into DA using the university's login info.

i clicked upload to tfrrs.  and nothing appears to be happening on the screen.  no exception, error message, dialogue box, nothing? nothing about permissions.  

will permissions be an issue as i am using the school's login info to DA which is different than my own info in RT?

You can email me the updated meet file if you like. When I run the version he previously sent to me it gives an error since there is no TFRRS Meet ID (actually it's set to 0)

Emailed the file.  the TFRRS Meet ID is now not 0

For the record... I am working with Kevin on this meet now. And I have pulled Jason Kronstat from DA into the conversation. It has something to do with how the meet was set up... seems like it was set up as a couple different meets. And different users... and maybe it's a "who owns the meet" issue. I really don't know at this point, but something is not right. Just need to all figure out what the proper procedure is with DA.


I'm experiencing the same thing with my upload.  Version 4.07 is now longer producing the exceptions that I was getting earlier.  All of the scoring and results appear to be working as expected.  When I attempt to export using the API, nothing happens.  I have my meet id setup.  Is there some magic somewhere that allows this to proceed?

Kevin and David's issue was resolved. It was an issue with how the meet was set up. Here are the results:



Am I correct in saying that you did not initially set up the meet using the "Download from TFRRS" option? I found the "nothing happens" hole after I examined what Kevin was experiencing last night. If you didn't go through the "Download from TFRRS" option then it never asks you go login to DA. So when you go to upload via the API it does nothing... instead of asking you to login there like it should.

This will be resolved in the next update; however, in the meantime you can resolve it by going to "Download from TFRRS" on the initial screen. Log in there. And then when it gives you a list of meets, simply click back to get out of that screen. Then open your meet back up. Once you do that then you'll be logged into DA/TFRRS and be able to upload to the api.

Thanks for your patience as we iron out the process for various different manners of setting meets up!

Thank you Jason,

You are correct.  The meet coach sent me the data obtained from somewhere else so I had to actually create an empty event on TFRRS for upload.  Your suggestion did the trick.

Thanks for all the help.

Reply to Discussion


Facebook Page

© 2019   Created by Jason Byrne.   Powered by

Badges  |  Report an Issue  |  Terms of Service